RPGM 2.0 Docs

RPGM Editor

The Editor is a complete IDE software for creating and generating .pgm files which can then be loaded in RPGM Client.

Editor

Getting started

The first thing to do is to create a new project. For this, press Ctrl+N, go to File -> New -> Project…, or click on New project… on the home tab.

New project

This wizard will help for the creation of the project. In the first field, type the name of your project.

Then choose the folder and if a subfolder must be created for the project. The directory root of the project will be where the .ppro file will be.

When the project is generated, create a first sequence. A sequence is a file which will executes GUIs, reports and R scripts in a specific order. Right click on the File explorer on the left and select Create Sequence…. Enter a name for the file, for example main.

New sequence

Now, open the project file, and type, drag and drop or select the previously created .pseq file in the First sequence field. That way, RPGM will know where the program will start.

First sequence

The project is now ready to have some steps. Let’s create a first GUI for asking some inputs to the final user. Right click on the File explorer and select Create GUI…. Enter a name for the file, for example input.

The last think to do is to add the new GUI to the sequence. Double click on the .pseq file in the File explorer and drag and drop the .pgui file from the File explorer in the Sequence editor. Also, don’t forget to add a Start step in the sequencer with the buttons on the left, and link the output of the Start step to the new GUI. Congratulations!

Sequencer

Executing and Exporting

You can test at any moment your project by either pressing the F5 key, or by going in Project menu then Execute. This will internally export your program and launch the client with it.

When you want to deploy your project for distribution, select Project -> Export… and then choose a .pgm file. The generated file must be imported on the client with the Open program… button.

Options

Just as in the client, you can select which R installation you want to use with the Options screen, which can be accessed with Tools -> Options…

Contextual help

With the F1 key, you will always get help on what you are currently working. For example:

  • Pressing F1 in the GUI Editor will open the GUI Editor documentation
  • Pressing F1 in a R script while the cursor is on a function will open the R documentation page about the function…
  • … except if the function is one of RPGM. The correct documentation will be opened.
  • And if a R function with this name is not found, it displays a simple search result on R documentation.

Interface

Top menu

The File, Edit, View and Help section of the top menu and/or its bar give access to all the common commands (creation, saving, copy/paste, window layout, help…). The third menu is Project.

Project menu

  • Execute executes the program currently opened. RPGM Client will start with the program. The shortcut is the F5 key.
  • Export creates a .pgm file of your project which can then be read by RPGM Client. Double clicking on a .pgm file will automatically open it with RPGM Client.

The next top-level menu is R

R menu

  • Stop R stops the R environment in the Editor.
  • Execute selection in R executes the selected R code.
  • Clear console output clears the console.
  • Excel spreadsheet helper shows the tool which helps to edit Excel files.
  • Compile C program compiles the C file opened and creates a .dll file.

The Tools top-level menu has only one field : Options. The Options screen is explained in the Installation & Configuration page of the documentation.

File Explorer

File Explorer

The All project tab contains a list of all created projects. A double click will open the project. This is a convenient window which is displayed by default when opening the Editor. A project can be removed from this list with a right click and the Remove from list option. On the top, you can filter the name of the project with the text field. The clock icon indicates that projects are sorted by “last time opened”, a click on this icon will switch to an alphanumerical sorting of the list.

The File Explorer tab displays the folder of the current project, with all the files and the folders in it.
A right click shows a context menu for performing basic file system and folder operations such as renaming, deleting or creating.
A double click on a file will open it in the editor, except if the file type is unknown (such as the D.txt file in the screenshot). In such case, the default program set in Windows for that filetype is used.
At the bottom of the File Explorer, a button opens the folder of the program in the Windows Explorer.
On its left, the Filter filenames field can filter the file and folders by writing a name.

The environment

The environment is the framework where the files are edited.

The environment

The tabs on the top are a list of the opened files. It is possible to reorder them with the mouse. Below is the current opened file. These files can be the project file .ppro, a sequence .pseq, R or C scripts, GUI .pgui or reports .prep.

The R console

R Console

The R console at the bottom contains a R environment similar to the standard R console. At the bottom you can write any R command and send it by pressing Enter. Up and Down arrow will prefill the control with recently entered commands. Also, having some code selected in a R script and pressing Ctrl+R will execute the selected code in the console.

Documentation

This window will display the R or the RPGM documentation. You can generally press F1 anywhere in the software to get help. See the Contextual help section of this page for more details. On the top left, the buttons will go back, forward and reload the page as in any web browser. On the top right you can search in the R documentation by typing a text in the field and pressing Enter.

On the bottom bar, you can search in the current webpage. Enter something in the field and use the Up and Down button next to it for going through the results.